码迷,mamicode.com
首页 > 其他好文 > 详细

[ACM] POJ 1611 The Suspects (并查集,输出第i个人所在集合的总人数)

时间:2014-07-17 10:37:49      阅读:296      评论:0      收藏:0      [点我收藏+]

标签:acm   并查集   

The Suspects
Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 21586   Accepted: 10456

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source


题意:

bubuko.com,布布扣

题意直接从YM那里复制过来的。http://www.cnblogs.com/yym2013/p/3845448.html

parent[i] 表示 i号节点的根节点是谁,sum[i] 表示以i号节点为根节点的总节点个数,那么sum[0]即为所求。

在合并的时候需要稍微处理一下,如果find(x)  fin(y)有一个为0时,始终把0作为根节点,也就是说,第0个节点始终在自己的集合中。 这样最后直接输出sum[0]就可以了。

代码:

#include <iostream>
using namespace std;
const int maxn=30010;
int parent[maxn];
int sum[maxn];
int st[maxn];

void init(int n)
{
    for(int i=0;i<n;i++)
    {
        parent[i]=i;
        sum[i]=1;
    }
}

int find(int x)
{
    return parent[x]==x?x:find(parent[x]);
}

void unite(int x,int y)
{
    int t1=find(x);
    int t2=find(y);
    if(t1==t2)
        return ;
    if(t1==0)//始终连接到根为0的节点上
    {
        parent[t2]=t1;
        sum[t1]+=sum[t2];
    }
    else if(t2==0)
    {
        parent[t1]=t2;
        sum[t2]+=sum[t1];
    }
    else //如果二者的根不为0 ,那就随便了。
    {
        parent[t1]=t2;
        sum[t2]+=sum[t1];
    }
}


int main()
{
    int n,m;
    while(cin>>n>>m&&(n||m))
    {
        init(n);
        int k;//每组多少个数
        while(m--)
        {
            cin>>k;
            cin>>st[0];//就算0个团体0个人,也要输入第一个人,汗
            k--;
            for(int i=1;i<=k;i++)
            {
                cin>>st[i];
                unite(st[i],st[i-1]);
            }
        }
        cout<<sum[0]<<endl;
    }
    return 0;
}



[ACM] POJ 1611 The Suspects (并查集,输出第i个人所在集合的总人数),布布扣,bubuko.com

[ACM] POJ 1611 The Suspects (并查集,输出第i个人所在集合的总人数)

标签:acm   并查集   

原文地址:http://blog.csdn.net/sr_19930829/article/details/37900239

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!