码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3872 计算对答案的贡献

时间:2015-10-10 00:12:22      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:

                                               D - Beauty of Array

Description

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

题意:给你一个数组,找出所有任意连续子序列中美数和,一段子序列美数和定义为:互异数的和
题解:计算对答案的贡献
技术分享
#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<cstdio>
#include<vector>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#pragma comment(linker, "/STACK:102400000,102400000")
using namespace std;
const int N=1010;
const int MAX=151;
const int MOD=1000000007;
const int INF=1000000000;
const double EPS=0.00000001;
typedef long long ll;
int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<0||ch>9){if(ch==-)f=-1;ch=getchar();}
    while(ch>=0&&ch<=9){x=x*10+ch-0;ch=getchar();}
    return x*f;
}
int num[1000100];
int main()
{
    int a,i,n,T;
    ll ans;
    scanf("%d", &T);
    while (T--) {
        scanf("%d", &n);
        ans=0;
        memset(num,0,sizeof(num));
        for (i=1;i<=n;i++) {
            scanf("%d", &a);
            ans+=(ll)(i-num[a])*(n-i+1)*a;
            num[a]=i;
        }
        printf("%lld\n", ans);
    }
    return 0;
}
代码

 

ZOJ 3872 计算对答案的贡献

标签:

原文地址:http://www.cnblogs.com/zxhl/p/4865476.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!