码迷,mamicode.com
首页 > 其他好文 > 详细

MANAGER

时间:2014-07-17 15:01:46      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   使用   

J - MANAGER(2.4.5)
Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

One of the programming paradigm in parallel processing is the producer/consumer paradigm that can be implemented using a system with a "manager" process and several "client" processes. The clients can be producers, consumers, etc. The manager keeps a trace of client processes. Each process is identified by its cost that is a strictly positive integer in the range 1 .. 10000. The number of processes with the same cost cannot exceed 10000. The queue is managed according to three types of requests, as follows:
  • a x - add to the queue the process with the cost x;
  • r - remove a process, if possible, from the queue according to the current manager policy;
  • p i - enforce the policy i of the manager, where i is 1 or 2. The default manager policy is 1
  • e - ends the list of requests.

There are two manager policies:
  • 1 - remove the minimum cost process
  • 2 - remove the maximum cost process

The manager will print the cost of a removed process only if the ordinal number of the removed process is in the removal list.

Your job is to write a program that simulates the manager process.

Input

The input is from the standard input. Each data set in the input has the following format:
  • the maximum cost of the processes
  • the length of the removal list
  • the removal list - the list of ordinal numbers of the removed processes that will be displayed; for example 1 4 means that the cost of the first and fourth removed processes will be displayed
  • the list of requests each on a separate line.

Each data set ends with an e request. The data sets are separated by empty lines.

Output

The program prints on standard output the cost of each process that is removed, provided that the ordinal number of the remove request is in the list and the queue is not empty at that moment. If the queue is empty the program prints -1. The results are printed on separate lines. An empty line separates the results of different data sets.

An example is given in the following:

Sample Input

5
2
1 3
a 2
a 3
r
a 4
p 2
r
a 5
r
e

Sample Output

2
5



#include <iostream>
#include<algorithm> 
using namespace std;
int cmp1(int a,int b)
{
	return a>b;
}
int cmp2(int a,int b)
{
	return a<b;
}
int main()
{
	
    int num;
    while(cin>>num&&num)
	{
		int p=1;
		int n;
		cin>>n;
		int a[1010]={0},b[1010]={0},c[2010]={0};
		int i;
		for(i=1;i<=n;i++)
			cin>>b[i];
		int a1=1,b1=1,c1=1;
		char ch;
		i=0;    
		while(cin>>ch&&ch!='e')
		{
			if(ch=='a')
			{
				cin>>a[a1];
				a1++;
			}
			if(ch=='p')
				cin>>p;
			if(ch=='r')
			{
				if(p==1)
				{
					sort(a+1,a+a1,cmp1);
					c[c1]=a[a1-1];
					c1++;
					a1=a1-1;
				}
				if(p==2)
				{
					sort(a+1,a+a1,cmp2);
					c[c1]=a[a1-1];
					c1++;
					a1=a1-1;
				}
			}
		}
		for(i=1;i<=n;i++)
			cout<<c[b[i]]<<endl;
		cout<<endl;
	}
	return 0;
}

/*
5
2
1 3
a 2
a 3
r
a 4
p 2
r
a 5
r
e
*/


刚开始提交WrongAnswer 后来注意到时sort函数的使用,数组开始下标从0开始还是从1开始sort括号里的的列表不同,

sort(a+1,a+a1,cmp1);
我的下标从1开始。

sort函数详情见http://blog.csdn.net/sunshumin/article/details/37756027

再提交时是PE错误,改成一次while循环加一个空行,ac。

MANAGER,布布扣,bubuko.com

MANAGER

标签:des   style   blog   http   color   使用   

原文地址:http://blog.csdn.net/sunshumin/article/details/37904267

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!