码迷,mamicode.com
首页 > 其他好文 > 详细

[BZOJ3874][AHOI2014] 宅男计划

时间:2015-10-13 00:04:27      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:

Description

  外卖店一共有N种食物,分别有1到N编号。第i种食物有固定的价钱Pi和保质期Si。第i种食物会在Si天后过期。JYY是不会吃过期食物的。比如JYY如果今天点了一份保质期为1天的食物,那么JYY必须在今天或者明天把这个食物吃掉,否则这个食物就再也不能吃了。保质期可以为0天,这样这份食物就必须在购买当天吃掉。JYY现在有M块钱,每一次叫外卖需要额外付给送外卖小哥外送费F元。送外卖的小哥身强力壮,可以瞬间给JYY带来任意多份食物。JYY想知道,在满足每天都能吃到至少一顿没过期的外卖的情况下,他可以最多宅多少天呢?
 

Input

  第一行包含三个整数M,F和N。
  接下来N行,第i行包含两个整数Pi和Si。
 

Output

  输出仅包含一行一个整数表示JYY可以宅的最多的天数。

 

Sample Input

32 5 2
5 0
10 2

Sample Output

3

HINT

【样例说明】


JYY的最佳策略是:第一天买一份食物1和一份食物2并且吃一份食物1;第二天吃一份食物2;第三天买一份食物1并且吃掉。
 

【数据规模与约定】

对于100%的数据满足0<=Si<=10^18,1<=F,Pi,M<=10^18,1<=N<=200。
 
 
 
题解:我不能确保这种方法的正确性,因为迄今为止我还没有看到其他能够复杂度能够承受的办法,最起码这样做的话,数据是可以过的,当然不排除数据不够全面。因为送物品非常自由,没有任何限制,所以我们要找一个合适的自变量进行枚举。可以发现,如果我们外卖的次数过少,那么就会出现一些食品性价比不高的情况;如果次数过多,那么就会浪费外卖运费。故可以从这里入手,因为可以看出这是一个类似于二次函数的函数。我们可以通过三分来查找峰值。
  那么对于每次的求值,就是以贪心为主体了。因为我们显然要价格便宜,保质期又长的食品,故我们将同保质期但价格偏高的去除,然后根据保质期从大到小排序,我们给每一次送餐都加上一个该食品,直到钱不够或者时间已经超过。
 
代码:
--------------------------------------------------------------------------------------------------

#include <cstdio>
#include <algorithm>
#define MAXN 205
using namespace std;

typedef long long ll;

struct Food { ll p, s; } tmp[MAXN], a[MAXN];

struct Cmp1
{
  bool operator () (Food x, Food y)
  {
    return x.s == y.s ? x.p < y.p : x.s < y.s;
  }
};
Cmp1 cmp1;

struct Cmp2
{
  bool operator () (Food x, Food y)
  {
    return x.p < y.p;
  }
};
Cmp2 cmp2;

ll t, m, f, n, tot;

ll getAns(ll o)
{
  ll nowm = m - f * o, d = 0, res = 0, tx;
  if (nowm < 0) return 0;
  for (int i = 1; i <= tot; i++)
  {
    ll s = a[i].s, p = a[i].p;
    if (d <= s) tx = min(s - d + 1, nowm / (p * o)), res += tx * o, nowm -= p * o * tx, d += tx;
    if (d <= s) tx = min(o, nowm / p), res += tx, nowm -= p * tx, d++;
  }
  return res;
}

void init()
{
  tot = 1;
  scanf("%I64d %I64d %I64d", &m, &f, &n);
  for (int i = 1; i <= n; i++) scanf("%I64d %I64d", &tmp[i].p, &tmp[i].s);
  sort(tmp + 1, tmp + n + 1, cmp1), a[1] = tmp[1];
  for (int i = 1; i <= n; i++) if (tmp[i].s > a[tot].s) a[++tot] = tmp[i];
  sort(a + 1, a + tot + 1, cmp2);
}

int main()
{
  freopen("food.in", "r", stdin);
  freopen("food.out", "w", stdout);
  scanf("%I64d", &t);
  while (t--)
  {
    init();
    if (f + a[1].p > m) { printf("0\n"); continue; }
    ll l = 1, r = m / (f + a[1].p), ans = max(getAns(l), getAns(r));
    while (l <= r)
    {
      ll tot = r - l + 1, ml = l + tot / 3, ansl = getAns(ml), mr = l + tot * 2 / 3, ansr = getAns(mr);
      if (ansl < ansr) ans = max(ansl, ans), l = ml + 1;
      else ans = max(ansr, ans), r = mr - 1;
    }
    for (int i = l; i <= r; i++) ans = max(ans, getAns(i));
    printf("%I64d\n",ans);
  }
  return 0;
}

--------------------------------------------------------------------------------------------------

[BZOJ3874][AHOI2014] 宅男计划

标签:

原文地址:http://www.cnblogs.com/jinkun113/p/4873174.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!