码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 1037 Gridland (简单)

时间:2014-07-17 18:12:39      阅读:247      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   strong   

Gridland

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Background

For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the "easy" problems like sorting, evaluating a polynomial or finding the shortest path in a graph. For the "hard" ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman to visit each of the towns once and only once and return to the starting point.


Problem

The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North-South or East-West is 1 unit. The length of the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 * 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 * 3-Gridland, the shortest tour has length 6.

bubuko.com,布布扣 
Figure 7: A traveling-salesman tour in 2 * 3-Gridland.

Input

The first line contains the number of scenarios.

For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.


Output

The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario ends with a blank line.


Sample Input

2
2 2
2 3


Sample Output

Scenario #1:
4.00

Scenario #2:
6.00 

 

 

       题意:就是给你n*m个点,每个都要遍历一遍,要你怎么走才是最短的,可以走斜对角。

       解题思路:因为每一个点都要走,当点的个数为偶数个时,就是n*m,当为奇数个是,最后一个可以走斜对角,最后一个的长度为1.41。注意格式,最后2个换行。

 

贴出代码:

 

#include <stdio.h>

int main()
{
    int n, i, m, T;
    float sum;
    scanf("%d", &T);
    for( i = 1; i<=T; i++)
    {
        scanf("%d%d", &n, &m);
        sum = m*n*1.0;
        if(m*n%2 == 0)
            printf("Scenario #%d:\n%.2f\n\n", i, sum);
        else
            printf("Scenario #%d:\n%.2f\n\n", i, sum+0.41);
    }
    return 0;
}

zoj 1037 Gridland (简单),布布扣,bubuko.com

zoj 1037 Gridland (简单)

标签:des   style   blog   http   color   strong   

原文地址:http://www.cnblogs.com/fengxmx/p/3851209.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!