码迷,mamicode.com
首页 > 其他好文 > 详细

F题 - A+B for Input-Output Practice (V)

时间:2015-10-15 20:36:11      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:

 
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

Your task is to calculate the sum of some integers. 
 

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

Sample Input

2
4 1 2 3 4
5 1 2 3 4 5
 

Sample Output

10
15
 
题解;增加输入案例个数,然后依次输入案例
 
#include<stdio.h>
int main()
{
    int T,n,a;
    scanf("%d",&T);
   while(T--)
   {
       int sum=0;
       scanf("%d",&n);
       for(int i=1;i<=n;i++)
     {
         scanf("%d",&a);
         sum=sum+a;
     }
      printf("%d\n",sum);
   }
    return 0;
}

 

F题 - A+B for Input-Output Practice (V)

标签:

原文地址:http://www.cnblogs.com/hfc-xx/p/4883400.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!