码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2739 Sum of Consecutive Prime Numbers

时间:2014-07-17 19:15:16      阅读:260      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   strong   


Sum of Consecutive Prime Numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18782   Accepted: 10308

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

Source


题意:给定一个数n,使它变成若干个连续素数的和,求这样的组合的个数。

思路:水题,一般思路。

AC代码:
import java.io.*;
import java.util.*;
public class Main {

	public static void main(String[] args) throws IOException {
		//Scanner scan=new Scanner (System.in);
		StreamTokenizer st = new StreamTokenizer(new BufferedReader(
				new InputStreamReader(System.in)));
		st.nextToken();
		int t=(int)st.nval;
		for(int i=0;i<t;i++){
			st.nextToken();
			int n=(int)st.nval;
			st.nextToken();
			int l=(int)st.nval;
			int count=0;
			int a[]=new int[n];
			for(int j=0;j<n;j++){
				st.nextToken();
				a[j]=(int)st.nval;
			}
			Arrays.sort(a);
			for(int j=0,k=n-1;j<=k;){
				if(a[j]+a[k]<=l){
					count++;
					j++;k--;
				}
				else{
					count++;
					k--;
				}
			}
			if(i!=0)
				System.out.println();
			System.out.println(count);
		}
	}

}


POJ 2739 Sum of Consecutive Prime Numbers,布布扣,bubuko.com

POJ 2739 Sum of Consecutive Prime Numbers

标签:des   style   http   java   color   strong   

原文地址:http://blog.csdn.net/kimi_r_17/article/details/37909725

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!