码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2782 Bin Packing

时间:2014-07-17 20:33:40      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   java   color   


Bin Packing
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5416   Accepted: 2452

Description

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that
  • each bin contains at most 2 items,
  • each item is packed in one of the q bins,
  • the sum of the lengths of the items packed in a bin does not exceed l .

You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q .

Input

The first line of the input contains the number of items n (1<=n<=105) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.

Output

Your program has to write the minimal number of bins required to pack all items.

Sample Input

10
80
70
15
30
35
10
80
20
35
10
30

Sample Output

6

Hint

The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.
bubuko.com,布布扣

Source


题意:给最大长度,最多放两个,使给出的长度组合成不大于最大长度的最小组合数。

思路:贪心。最长的和最短的组合如果小于最大长度的话。

AC代码:(代码里有多组数据,懒得改bubuko.com,布布扣
 java.io.*;
import java.util.*;
public class Main {

	public static void main(String[] args) throws IOException {
		//Scanner scan=new Scanner (System.in);
		StreamTokenizer st = new StreamTokenizer(new BufferedReader(
				new InputStreamReader(System.in)));
		st.nextToken();
		int t=(int)st.nval;
		for(int i=0;i<t;i++){
			st.nextToken();
			int n=(int)st.nval;
			st.nextToken();
			int l=(int)st.nval;
			int count=0;
			int a[]=new int[n];
			for(int j=0;j<n;j++){
				st.nextToken();
				a[j]=(int)st.nval;
			}
			Arrays.sort(a);
			for(int j=0,k=n-1;j<=k;){
				if(a[j]+a[k]<=l){
					count++;
					j++;k--;
				}
				else{
					count++;
					k--;
				}
			}
			if(i!=0)
				System.out.println();
			System.out.println(count);
		}
	}

}


POJ 2782 Bin Packing,布布扣,bubuko.com

POJ 2782 Bin Packing

标签:des   style   blog   http   java   color   

原文地址:http://blog.csdn.net/kimi_r_17/article/details/37909439

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!