码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1258:Sum It Up

时间:2015-10-16 23:06:25      阅读:218      评论:0      收藏:0      [点我收藏+]

标签:

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3695    Accepted Submission(s): 1873


Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 

Output
For each test case, first output a line containing ‘Sums of‘, the total, and a colon. Then output each sum, one per line; if there are no sums, output the line ‘NONE‘. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 

Sample Input
4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
 

Sample Output
Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25

    题意没什么特别的,非常easy也就看懂了。。也就不多说了。

难点:
这题要推断是否反复,反复的式子仅仅出现一次
也就要保证DFS開始的起点不一样。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 1000 + 5;
int n, m;
int num[M];      //数据输入
int ans[M];     //数据输出
int vist;      //标记
int step;     
bool flag;

void dfs(int x, int cnt)
{
    if(cnt>n)
        return ;
    else if(cnt==n)      //符合要求则输出
    {
        flag=true;
        printf("%d", ans[1]);
        for(int i=2; i<step; i++)
            printf("+%d", ans[i]);
        printf("\n");
        return ;
    }
    int vist=-1;      //用于推断DFS開始的起点是否同样
    for(int j=x+1; j<=m; j++)
    {
        if(num[j]!=vist)
        {
            ans[step++]=num[j];
            vist=num[j];
            dfs(j, cnt+num[j]);
            step--;
        }
    }
}

int main()
{
    while(scanf("%d%d", &n, &m) &&n &&m)
    {
        flag=false;
        step=1;
        memset(num, 0, sizeof(num));     //数据初始化
        memset(ans, 0, sizeof(ans));
        for(int i=1; i<=m; i++)
            scanf("%d", &num[i]);
        printf("Sums of %d:\n", n);
        dfs( 0, 0 );
        if(!flag)
            printf("NONE\n");      
    }

    return 0;
}


版权声明:本文博主原创文章。博客,未经同意不得转载。

HDU 1258:Sum It Up

标签:

原文地址:http://www.cnblogs.com/gcczhongduan/p/4886479.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!