码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5504 GT and sequence(BestCoder Round #60 )

时间:2015-10-18 11:32:48      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:   bc   

GT and sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 334 Accepted Submission(s): 85


Problem Description
You are given a sequence of N技术分享 integers.

You should choose some numbers(at least one),and make the product of them as big as possible.

It guaranteed that **the absolute value of** any product of the numbers you choose in the initial sequence will not bigger than 2技术分享63技术分享?1技术分享.

Input
In the first line there is a number T技术分享 (test numbers).

For each test,in the first line there is a number N技术分享,and in the next line there are N技术分享 numbers.

1T1000技术分享
1N62技术分享

You‘d better print the enter in the last line when you hack others.

You‘d better not print space in the last of each line when you hack others.

Output
For each test case,output the answer.

Sample Input
1 3 1 2 3

Sample Output
6

Source

题意:给定一个序列,从中选出任意个数的乘积最大值。
分析:此题太多坑,得慢慢发现。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

int main()
{
    int T;
    ll n,x,sum;
    cin>>T;
    while(T--)
    {
        cin>>n;
        sum = 0;
        int k=0,re=0;
        ll maxx = -INF;
        for(int i=0; i<n; i++)
        {
            cin>>x;
            if(x == 0) {re++; continue;}
            if(x < 0)
            {
                k++;
                maxx = max(maxx, x);
            }
            if(i == re) sum = x;
            else sum *= x;
        }
        //cout<<re<<" "<<k<<endl;
        if(k%2&&n!=1&&!(k==1&&re+k==n)) sum /= maxx;
        if(re>0&&(sum<0||n==1)) sum = 0;
        
        cout<<sum<<endl;
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu5504 GT and sequence(BestCoder Round #60 )

标签:   bc   

原文地址:http://blog.csdn.net/d_x_d/article/details/49226275

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!