码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ 2240】Arbitrage

时间:2015-10-23 20:06:40      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:

Arbitrage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18408   Accepted: 7796

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

 
可以用Floyd过。
需要注意的是,他是求一个像环一样的最长路径。
所以这里是和普通的Floyd有所不同,但本质上还是传递闭包。
 
#include <cstdio>
#include <cstring>
#include <iostream>
#include <string>
#include <map>

using namespace std;

map<string, int> ID;
double dis[35][35];
int n, m;

int main()
{
    int kase = 0;
    while (scanf("%d", &n) == 1 && n)
    {
        string s, s1;
        ID.clear();
        for (int i = 0; i < n; ++i)
        {
            cin >> s;
            ID[s] = i;
        }
        for (int i = 0; i < n; ++i)
            for (int j = 0; j < n; ++j)
                dis[i][j] = 1.0;
        scanf("%d", &m);
        for (int i = 0; i < m; ++i)
        {
            double x;
            cin >> s >> x >> s1;
            int id1 = ID[s], id2 = ID[s1];
            dis[id1][id2] = x;
        }
        for (int k = 0; k < n; ++k)
            for (int i = 0; i < n; ++i)
                for (int j = 0; j < n; ++j)
                    dis[i][j] = max(dis[i][j], dis[i][k] * dis[k][j]);
        bool flag = true;
        printf("Case %d: ", ++kase);
        for (int i = 0; i < n; ++i)
            if (dis[i][i] > 1)
            {
                flag = false;
                printf("Yes\n");
                break;
            }
        if (flag) printf("No\n");
    }
    return 0;
}

 

【POJ 2240】Arbitrage

标签:

原文地址:http://www.cnblogs.com/albert7xie/p/4905518.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!