码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ 1469】COURSES

时间:2015-10-24 14:16:32      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:

COURSES
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19760   Accepted: 7784

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student1 1 Student1 2 ... Student1 Count1 
Count2 Student2 1 Student2 2 ... Student2 Count2 
... 
CountP StudentP 1 StudentP 2 ... StudentP CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

 
明显的二分图。
因为数据太小直接用矩阵存储图。
#include <cstdio>
#include <cstring>

using namespace std;

int p, n, left[305];
bool g[105][305], v[305];

bool dfs(int x)
{
    for (int i = 1; i <= n; ++i)
        if (g[x][i] && v[i])
        {
            v[i] = false;
            if (left[i] == 0 || dfs(left[i]))
            {
                left[i] = x;
                return true;
            }
        }
    return false;
}

int main()
{
    int Test;
    scanf("%d", &Test);
    while (Test--)
    {
        scanf("%d%d", &p, &n);
        memset(g, false, sizeof(g));
        for (int i = 1; i <= p; ++i)
        {
            int num, x;
            scanf("%d", &num);
            while (num--)
            {
                scanf("%d", &x);
                g[i][x] = true;
            }
        }
        int ans = 0;
        memset(left, 0, sizeof(left));
        for (int i = 1; i <= p; ++i)
        {
            memset(v, true, sizeof(v));
            if (dfs(i)) ans++;
        }
        printf("%s\n", ans == p ? "YES" : "NO");
    }
    return 0;
}

 

【POJ 1469】COURSES

标签:

原文地址:http://www.cnblogs.com/albert7xie/p/4906695.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!