标签:poj2406
Power Strings
Time Limit: 3000MS |
|
Memory Limit: 65536K |
Total Submissions: 31388 |
|
Accepted: 13074 |
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
题意:给定一个串,它一定是某个前缀重复K次组成的,求K的最大值。
题解:利用next数组求最小循环节点len-next[len],注意还需判断len能否整除这个节点,若不能,那么k==1,否则k==len/最小循环节点。
#include <stdio.h>
#define maxn 1000002
char str[maxn];
int next[maxn], len, cir;
void getNext()
{
int i = 0, j = -1;
next[0] = -1;
while(str[i]){
if(j == -1 || str[i] == str[j]){
++i; ++j;
next[i] = j; //mode 1
}else j = next[j];
}
len = i;
}
int main()
{
//freopen("stdin.txt", "r", stdin);
while(scanf("%s", str) == 1){
if(str[0] == '.') break;
getNext();
cir = len - next[len];
if(len % cir != 0) printf("1\n");
else printf("%d\n", len / cir);
}
return 0;
}
POJ2406 Power Strings 【KMP】,布布扣,bubuko.com
POJ2406 Power Strings 【KMP】
标签:poj2406
原文地址:http://blog.csdn.net/chang_mu/article/details/37929257