码迷,mamicode.com
首页 > 其他好文 > 详细

CCPC Ancient Go

时间:2015-10-28 14:21:16      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:

Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

  • The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
  • Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
  • The chess of the same color makes connected components(connected by the board lines), for each of the components, if it‘s not connected with any of the empty cells, this component dies and will be removed from the game board.
  • When one of the player makes his move, check the opponent‘s components first. After removing the dead opponent‘s components, check with the player‘s components and remove the dead components.

One day, Yu Zhou was playing ancient go with Su Lu at home. It‘s Yu Zhou‘s move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu‘s chess.

Input

The first line of the input gives the number of test cases, T(1T100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. . represents an empty cell. x represents a cell with black chess which owned by Yu Zhou. o represents a cell with white chess which owned by Su Lu.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu‘s components. Can not kill in one move!!! otherwise.

Sample input and output

Sample InputSample Output
2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o
Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!

Hint

In the first test case, Yu Zhou has 4 different ways to kill Su Lu‘s component.

In the second test case, there is no way to kill Su Lu‘s component.

#include<cstdio>
#include<cstring>
#include<stack>
#include<vector>
#include<queue>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
const int oo = 1e9+7;
const int maxn = 3*1e6+7;
int dir[4][2] = {{0,1},{0,-1},{1,0},{-1,0}};
int vis[20][20];
char maps[20][20];
int judge(int x, int y)
{
    vis[x][y] = 1;
    int i, sx, sy;
    for(i = 0; i < 4; i++)
    {
        sx = x + dir[i][0];
        sy = y + dir[i][1];
        if(sx < 0 || sx >= 9 || sy < 0 || sy >= 9 || vis[sx][sy]) continue;
        if(maps[sx][sy] == ‘.‘) return 0;
        if(maps[sx][sy] == ‘o‘ && !judge(sx, sy)) return 0;

    }
    return 1;
}
int dfs(int x, int y)
{
    int i;
    for(i = 0; i < 4; i++)
    {
        int sx, sy;
        sx = x+dir[i][0];
        sy = y+dir[i][1];
		if(maps[sx][sy] == ‘o‘)
        if(sx >= 0 && sx < 9 && sy >= 0 && sy < 9)
        {
            memset(vis, 0, sizeof(vis));
            if(judge(sx, sy))
                return 1;
        }
    }
    return 0;
}
int main()
{
    int T, i, j, cas = 1, ok;
    scanf("%d", &T);
    while(T--)
    {
        ok = 0;
        for(i = 0; i < 9; i++)
            scanf("%s", maps[i]);

        for(i = 0; i < 9; i++)
        {
            for(j = 0; j < 9; j++)
            {
                if(maps[i][j] == ‘.‘)
                {
					maps[i][j] = ‘x‘;
                    ok = dfs(i, j);
					maps[i][j] = ‘.‘;
                }
                if(ok == 1) break;
            }
            if(ok == 1)break;
        }
        if (ok == 1) printf ("Case #%d: Can kill in one move!!!\n", cas++);
        else printf ("Case #%d: Can not kill in one move!!!\n", cas++);
    }
    return 0;
}

  

CCPC Ancient Go

标签:

原文地址:http://www.cnblogs.com/PersistFaith/p/4917046.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!