码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1015 Safecracker (纯暴力)

时间:2014-07-19 18:00:31      阅读:220      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   java   color   使用   

Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8183    Accepted Submission(s): 4143


Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein‘s secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn‘t exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution‘ if there is no correct combination. Use the exact format shown below."
 

 

Sample Input
1 ABCDEFGHIJKL 11700519 ZAYEXIWOVU 3072997 SOUGHT 1234567 THEQUICKFROG 0 END
 

 

Sample Output
LKEBA YOXUZ GHOST no solution
 

 

 

        题意:给你5到12个字符,A到Z,A代表1,Z代表16,要你求出符合这个规则的字符:v - w^2 + x^3 - y^4 + z^5 = target 。并且是按照字典序的排序来,然后输出这5个字符。

 

       解题思路:因为数据量一点都不大,所以就选择了纯暴力,网上还有什么用DFS,感觉也是在递归暴力啊,嘿嘿。如果当前的这个字母被占用则不能使用,就要跳过继续,不断的循环判断是否符合这个,若符合则跳出。

 

贴出代码:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int cmp(const void* a,const void* b)
{
    return *(char*)a - *(char*)b;
}

int main()
{
    int m, mark;
    int visited[15];
    char str[15];
    char c1, c2, c3, c4, c5;
    int n1, n2, n3, n4, n5, n;
    while(scanf("%d%s", &n, str)!=EOF)
    {
        if(n==0 && strcmp(str, "END")==0)
            break;
        for(int i = 0; i<12; i++)
            visited[i] =0;
        m = strlen(str);
        qsort(str, m, sizeof(str[0]), cmp);
        if(m<5)
        {
            printf("no solution\n");
            continue;
        }
        mark = 0;
        for(int i1 = m-1; i1>=0; i1--)
        {
            visited[i1] = 1;
            for(int i2 = m-1; i2>=0; i2--)
            {
                if(visited[i2])
                    continue;
                visited[i2] = 1;
                for(int i3 = m-1; i3>=0; i3--)
                {
                    if(visited[i3])
                        continue;
                    visited[i3] = 1;
                    for(int i4 = m-1; i4>=0; i4--)
                    {
                        if(visited[i4])
                            continue;
                        visited[i4] = 1;
                        for(int i5 = m-1; i5>=0; i5--)
                        {
                            if(visited[i5])
                                continue;
                            n1 = str[i1]-A+1;
                            n2 = str[i2]-A+1;
                            n3 = str[i3]-A+1;
                            n4 = str[i4]-A+1;
                            n5 = str[i5]-A+1;
                            if(n1+n3*n3*n3+n5*n5*n5*n5*n5 == n+n2*n2+n4*n4*n4*n4)
                            {
                                mark = 1;
                                c5 = str[i5];
                                break;
                            }
                        }
                        visited[i4] = 0;
                        if(mark)
                        {
                            c4 = str[i4];
                            break;
                        }
                    }
                    visited[i3] = 0;
                    if(mark)
                    {
                        c3 = str[i3];
                        break;
                    }
                }
                visited[i2] = 0;
                if(mark)
                {
                    c2 = str[i2];
                    break;
                }
            }
            visited[i1] = 0;
            if(mark)
            {
                c1 = str[i1];
                break;
            }
        }
        if(mark)
            printf("%c%c%c%c%c\n", c1, c2, c3, c4, c5);
        else
            printf("no solution\n");


    }

    return 0;
}

hdu 1015 Safecracker (纯暴力),布布扣,bubuko.com

hdu 1015 Safecracker (纯暴力)

标签:des   style   blog   java   color   使用   

原文地址:http://www.cnblogs.com/fengxmx/p/3853691.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!