码迷,mamicode.com
首页 > 其他好文 > 详细

C Looooops(扩展欧几里德)

时间:2015-10-29 23:21:59      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:

C Looooops

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 3
Problem Description
A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C)

statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.
 

 

Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.
 

 

Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
 

 

Sample Input
3 3 2 16 3 7 2 16 7 3 2 16 3 4 2 16 0 0 0 0
 

 

Sample Output
0 2 32766 FOREVER
 题解:
输出lld老是wa,改成I64就过了。。。还有(LL)1<<k,也要加LL,否则还会wa
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
typedef long long LL;
void e_gcd(LL a,LL b,LL &d,LL &x,LL &y){
    if(!b){
        d=a;
        x=1;
        y=0;
    }
    else{
        e_gcd(b,a%b,d,x,y);
        LL temp=x;
        x=y;
        y=temp-a/b*y;
    }
}
void cal(LL a,LL b,LL c){
    LL d,x,y;
    e_gcd(a,b,d,x,y);
    if(c%d!=0){
        puts("FOREVER");
        return;
    }
    x*=c/d;
    b/=d;
    if(b<0)b=-b;
     x%=b;
    if(x<0)x+=b;
    printf("%I64d\n",x);
    return;
}
int main(){
    LL A,B,C,k;
    while(~scanf("%lld%lld%lld%lld",&A,&B,&C,&k),A|B|C|k){
        //C*x+2^ky=B-A;
        cal(C,(LL)1<<k,B-A);
    }
    return 0;
}

 

C Looooops(扩展欧几里德)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/4921950.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!