码迷,mamicode.com
首页 > 其他好文 > 详细

Designing Efficient Algorithms [Examples]~E - Subsequence

时间:2015-10-31 11:26:30      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input Many test cases will be given. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output For each the case the program has to print the result on separate line of the output file.

Sample Input

10 15

5 1 3 5 10 7 4 9 2 8

5 11

1 2 3 4 5

Sample Output

2

3

解题思路:题目意思:有n个正整数组成一个序列。给定整数S,求长度最短的连续序列,使它们的和大于或等于S。

程序代码:

#include"stdio.h"
#include"algorithm"
using namespace std;
const int N=100010;
int a[N],b[N];
int main()
{
    int n,s,i;
    while(scanf("%d%d",&n,&s)!=EOF)
    {
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        b[0]=0;
        for(i=1;i<=n;i++)
            b[i]=b[i-1]+a[i];
        int ans=n+1;
        i=1;
        for(int j=1;j<=n;j++)
        {
            if(b[i-1]>b[j]-s)continue;
            while(b[i]<=b[j]-s)i++;
            ans=min(ans,j-i+1);
        }
        printf("%d\n",ans==n+1?0:ans);
    }
    return 0;
}

 

Designing Efficient Algorithms [Examples]~E - Subsequence

标签:

原文地址:http://www.cnblogs.com/chenchunhui/p/4925063.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!