码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5512 Pagodas(2015ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学) )

时间:2015-10-31 21:39:41      阅读:826      评论:0      收藏:0      [点我收藏+]

标签:

Pagodas

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 14 Accepted Submission(s): 13


Problem Description
n技术分享 pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1技术分享 to n技术分享. However, only two of them (labelled a技术分享 and b技术分享, where 1abn技术分享) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i?{a,b} and 1in)技术分享 if there exist two pagodas standing erect, labelled j技术分享 and k技术分享 respectively, such that i=j+k技术分享 or i=j?k技术分享. Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.

Input
The first line contains an integer t (1t500)技术分享 which is the number of test cases.
For each test case, the first line provides the positive integer n (2n20000)技术分享 and two different integers a技术分享 and b技术分享.

Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.

Sample Input
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12

Sample Output
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka

Source

题意:1到n个塔,Yuwgna和Iaka两人从a,b两点开始修建塔,每次可以修建塔的位置i=j+k或i=j-k;j和k为已修建好的塔的位置,Yuwgna开始修,最后谁不能修了谁就输了,问最后谁赢。
分析:最简单的签到题;首先判断a和b中有没有1,如果有的话,那么每个位置都能修建塔;如果没有,在判断a和b是不是互质,如果互质,那么肯定会出现1的情况,也就是1这位置总有一回合会修建塔,所以也是每个位置都能修建塔,然后就是不互质的情况了,不互质的话,可以修建塔的位置的个数就只有n/gcd(a, b);然后最后判断总共可以修建的塔的个数是奇数还是偶数就ok了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))

int main()
{
    int T,n,a,b;
    cin>>T;
    for(int cas=1; cas<=T; cas++)
    {
        cin>>n>>a>>b;
        if(b<a) swap(a, b);
        cout<<"Case #"<<cas<<": ";
        int t=__gcd(a, b);//a和b的最大公约数
        int cnt;
        if(a==1)//有1
            cnt=n;
        else
        {
            if(t!=1)//不互质
                cnt=n/t;
            else
                cnt=n;
        }
        if(cnt&1)
            cout<<"Yuwgna"<<endl;
        else
            cout<<"Iaka"<<endl;
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu5512 Pagodas(2015ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学) )

标签:

原文地址:http://blog.csdn.net/d_x_d/article/details/49534679

(0)
(1)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!