码迷,mamicode.com
首页 > 其他好文 > 详细

Almost Sorted Array

时间:2015-11-01 16:39:51      阅读:259      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,…,an, is it almost sorted?
 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,…,an.

1≤T≤2000
2≤n≤105
1≤ai≤105
There are at most 20 test cases with n>1000.
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input

3
3
2 1 7
3
3 2 1
5
3 1 4 1 5

 

Sample Output

YES
YES
NO

题意:给定一个序列 问:去掉一个元素能否成为有序序列。

#include<cstdio>
#include<cstring>
#include<stack>
#include<vector>
#include<queue>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
const int oo = 1e9+7;
const int maxn = 1e6+7;
typedef long long LL;
int ac[maxn];
void up(int n, int &flag, int &cnt)
{
    int i, p=1, index=1;///index标记不符合题意的点的下标
    flag = cnt = 0;///cnt标记不符合题意的点的个数
    for(i = 2; i <= n; i++)
    {
        if(ac[i] >= ac[i-1]) p++;
        else
        {
            cnt++;
            index = i;
        }
    }
    if(p == n) flag = 1;///原序列符合要求
    if(cnt == 1)///只存在一个不符合题意的点
    {
        if(index == n || index==2 || ac[index-1] <= ac[index+1] || ac[index-2] <= ac[index])
            flag = 1;
    }
    if(cnt == 0) flag = 1;
}
void down(int n, int &flag, int &cnt)
{
    int i, p=1, index=1;///index标记不符合题意的点的下标
    flag = cnt = 0;///cnt标记不符合题意的点的个数
    for(i = 2; i <= n; i++)
    {
        if(ac[i] <= ac[i-1]) p++;
        else
        {
            cnt++;
            index = i;
        }
    }
    if(p == n) flag = 1;///原序列符合要求
    if(cnt == 1)///只存在一个不符合题意的点
    {
        if(index == n || index==2 || ac[index-1] >= ac[index+1] || ac[index-2] >= ac[index])
            flag = 1;
    }
    if(cnt == 0) flag = 1;
}
int main()
{
    int T, i, n, flag, cnt;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        for(i = 1; i <= n; i++)
            scanf("%d", &ac[i]);
        flag = cnt = 0;
        up(n, flag, cnt);///上升序列
        if(flag == 0)
        down(n, flag, cnt);///下降序列
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

Almost Sorted Array

标签:

原文地址:http://www.cnblogs.com/PersistFaith/p/4928050.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!