Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11319 Accepted Submission(s): 4654
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup
time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l‘ and weight w‘ if l<=l‘ and w<=w‘. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents
the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers
are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
AC代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct Node
{
int w,l;
int y;
}a[5010];
bool cmp(Node a,Node b)
{
if(a.l==b.l)
return a.w>b.w;
return a.l>b.l;
}
int main()
{
int t,n,i,j,p,weight;
scanf("%d",&t);
while(t--)
{
p=0;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&a[i].l,&a[i].w);
a[i].y=1;
}
sort(a,a+n,cmp);
for(i=0;i<n;i++)
{
if(a[i].y==1)
{
a[i].y=0;
p++;
weight=a[i].w;
for(j=i+1;j<n;j++)
{
if(a[j].w<=weight&&a[j].y==1)
{a[j].y=0;
weight=a[j].w;
}
}
}
}
printf("%d\n",p);
}
return 0;
}