码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1018 Big Number

时间:2015-11-05 00:27:32      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31846    Accepted Submission(s): 14853


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

 

Sample Input
2
10
20
 

 

Sample Output
7
19
 
 
 
 
法一:

#include<stdio.h>
#include<math.h>
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
int m,i;
double s=0;
scanf("%d",&m);
for(i=1;i<=m;i++)
s=s+log10(double(i));
printf("%d\n",(int)s+1);
}
return 0;
}

 

 

 

 

法二:

#include<stdio.h>
#include<math.h>
#define p 3.14159265
#define e 2.71828182
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
int m,i;
double s;
scanf("%d",&m);
s=log10(2*p*m)/2+m*log10(m/e);
printf("%d\n",(int)s+1);
}
return 0;
}


 











HDU 1018 Big Number

标签:

原文地址:http://www.cnblogs.com/-lgh/p/4937832.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!