码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1541 Stars

时间:2014-07-19 18:27:18      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   strong   

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4402    Accepted Submission(s): 1748


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

bubuko.com,布布扣

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
1 2 1 1 0
 
树状数组入门题:

输入按y坐标递增的,y坐标相同则按x坐标递增;每输入一个点,可以统计出(x,y)左下方的所有点个数(即横坐标小于x),然后更新横坐标大于x的各点值。

#include"stdio.h"
#include"string.h"
#define N 32005
int ans[N],c[N];
int lowbit(int i)
{
    return i&(-i);
}
int getsum(int x)  //统计出横坐标小于等于x的点个数
{
    int i,sum=0;
    for(i=x;i>0;i-=lowbit(i))
    {
        sum+=c[i];
    }
    return sum;
}
void modify(int x,int d)      //更新横坐标大于等于x的点个数
{
    int i;
    for(i=x;i<N;i+=lowbit(i))
        c[i]+=d;
}
int main()
{
    int i,n,x,y;
    while(scanf("%d",&n)!=-1)
    {
        memset(c,0,sizeof(c));
        memset(ans,0,sizeof(ans));
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            x++;          //x++的原因:如果x=0更新时就会出现死循环所以都++
            ans[getsum(x)]++;
            modify(x,1);
        }
        for(i=0;i<n;i++)
        {
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}




hdu 1541 Stars,布布扣,bubuko.com

hdu 1541 Stars

标签:des   style   http   java   color   strong   

原文地址:http://blog.csdn.net/u011721440/article/details/37961017

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!