码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1753 Flip Game

时间:2014-07-19 23:42:59      阅读:405      评论:0      收藏:0      [点我收藏+]

标签:c++   poj   

Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30062   Accepted: 13036

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

bubuko.com,布布扣Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4



#include<iostream>
#include<cstring>
using namespace std;

int a[6][6];
int ans;

int ch()
{
	int i,j;
	for(i=0;i<4;i++)
		for(j=0;j<4;j++)
			if(a[i][j]!=a[0][0])
				return 0;
	 return 1;
}

void f(int x,int y)
{
	a[x][y]=!a[x][y];
	a[x+1][y]=!a[x+1][y];
	a[x][y+1]=!a[x][y+1];
	if(x>0)  a[x-1][y]=!a[x-1][y];
	if(y>0)  a[x][y-1]=!a[x][y-1];
}

void s(int x,int y)
{
	int i,j;
	if(x==16)
	{
		if(ch()&&y<ans)   ans=y;
	}
	else
	{
		i=x/4;
		j=x%4;
		s(x+1,y);
		f(i,j);
		s(x+1,y+1);
		f(i,j);
	}
}





int main()
{
	char c;
	int i,j;
	memset(a,0,sizeof(a));
	for(i=0;i<4;i++)
	{
		for(j=0;j<4;j++)
		{
			cin>>c;
			if(c=='b')
				a[i][j]=0;
			else
				a[i][j]=1;
		}
		getchar();
	}
	ans=10000;
	s(0,0);
	if(ans!=10000)   cout<<ans<<endl;
	else   cout<<"Impossible\n";
	return 0;
}


POJ 1753 Flip Game

标签:c++   poj   

原文地址:http://blog.csdn.net/hyccfy/article/details/37968007

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!