标签:c++ hduj
Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29480 Accepted Submission(s): 11136
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where
m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
#include<stdio.h>
int gcd(int a,int b)
{
return b==0?a:gcd(b,a%b);
}
int main()
{
int n,a,b,i,m;
scanf("%d",&m);
while(m--)
{
scanf("%d%d",&n,&a);
for(i=1;i<n;i++)
{
scanf("%d",&b);
a=a/gcd(a,b)*b;
}
printf("%d\n",a);
}
return 0;
}
HDUJ 1019 Least Common Multiple
标签:c++ hduj
原文地址:http://blog.csdn.net/hyccfy/article/details/37967633