码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1171 Big Event in HDU

时间:2014-07-19 23:32:07      阅读:297      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   java   color   os   

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22611    Accepted Submission(s): 7942


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don‘t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
20 10 40 40
 
题意:给出每个物体的价值和物体的数量,如何分使得A,B所得价值最接近并且A的价值不能小于B

<span style="font-size:18px;">#include<stdio.h>
#include<iostream>
using namespace std;
int dp[500000];
int v[10000];
int max(int x,int y)
{
	return (x>y?x:y);
}
int main ()
{
	int t,a,b,i,j;
	int sum,l;
	while(cin>>t)
	{
		if(t<0) break;
		sum=0;
		l=0;
		memset(dp,0,sizeof(dp));
		memset(v,0,sizeof(v));
		for(i=1;i<=t;i++)
		{
			cin>>a>>b;
			while(b--)   // 把第i种物品 换成 b件 01背包中的物品
			{
				v[l++]=a;  
				sum+=a; 
			}
		}
		
		for(i=0;i<l;i++)    // 01背包 (l件物品)
			for(j=sum/2;j>=v[i];j--)   // "背包容量"为总价值的一半
				dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
			
			cout<<sum-dp[sum/2]<<' '<<dp[sum/2]<<endl;
	}
	return 0;
}</span>


hdu 1171 Big Event in HDU,布布扣,bubuko.com

hdu 1171 Big Event in HDU

标签:des   style   blog   java   color   os   

原文地址:http://blog.csdn.net/fyxz1314/article/details/37967165

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!