码迷,mamicode.com
首页 > 其他好文 > 详细

HUDJ 1021 Fibonacci Again

时间:2014-07-19 23:43:09      阅读:391      评论:0      收藏:0      [点我收藏+]

标签:hduj   c++   

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36028    Accepted Submission(s): 17385


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
0 1 2 3 4 5
 

Sample Output
no no yes no no no


#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	int n;
	while(cin>>n)
	{
		if(n==2)   cout<<"yes\n";
		else  if((n-2)%4==0)    cout<<"yes\n";
		else   cout<<"no\n";
	}

	return 0;
}


HUDJ 1021 Fibonacci Again

标签:hduj   c++   

原文地址:http://blog.csdn.net/hyccfy/article/details/37966099

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!