标签:c++
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s[1000005]; //题目没说 结果开小了就runtime error。。
int next[1000005];
int s1,ss;
void getnext(char *s)
{
int i=0;
int j=-1;
next[0]=-1;
while(i<s1)
{
if(j==-1||s[i]==s[j])
{
++i;
++j;
next[i]=j;
}
else
j=next[j];
}
i=s1-j;
if(s1%i==0)
ss=s1/i;
else
ss=1;
return ;
}
int main()
{
while(scanf("%s",s))
{
if(s[0]=='.')
break;
s1=strlen(s);
getnext(s);
cout<<ss<<endl;
}
return 0;
}
poj 2406 Power Strings KMP
标签:c++
原文地址:http://blog.csdn.net/axuan_k/article/details/37965983