码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 5500 Reorder the Books

时间:2015-11-14 19:11:04      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:

Reorder the Books

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 919    Accepted Submission(s): 501


Problem Description
dxy has a collection of a series of books called "The Stories of SDOI",There are n(n19)技术分享 books in this series.Every book has a number from 1技术分享 to n技术分享 .

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

One day Evensgn visited dxy‘s home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing himself in the story,he disrupted the order of the books.

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift.
 

 

Input
There are several testcases.

There is an positive integer T(T30)技术分享 in the first line standing for the number of testcases.

For each testcase, there is an positive integer n技术分享 in the first line standing for the number of books in this series.

Followed n技术分享 positive integers separated by space standing for the order of the disordered books,the ith技术分享 integer stands for the ith技术分享 book‘s number(from top to bottom).


Hint:
For the first testcase:Moving in the order of book3,book2,book1技术分享 ,(4,1,2,3)(3,4,1,2)(2,3,4,1)(1,2,3,4)技术分享 ,and this is the best way to reorder the books.
For the second testcase:It‘s already ordered so there is no operation needed.
 

 

Output
For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.
 

 

Sample Input
2
4
4 1 2 3
5
1 2 3 4 5
 

 

Sample Output
3
0
 
题意:一摞书顺序乱了,让你按照序号从小到大的顺序将其排列整齐,一次只能拿一本书,且必须放在最上边,问最少多少步可以实现
题解:先算出已经按顺序排好的书本的个数sum(注意这个序列并不一定连续,而且必须是从某个数到n的序列),用n减去sum即可
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define MAX 100100
using namespace std;
int a[MAX];
int main()
{
    int n,m,t,i,j;
    scanf("%d",&t);
    int maxx,ans;
    while(t--)
    {
        scanf("%d",&n);
        maxx=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(maxx<a[i])
            {
                maxx=a[i];
                ans=i;
            }
        }
        int ant=ans,sum=0;
        for(j=ans;j>=1;j--)
        {
            if(a[j]==a[ant]-1)
            {
                sum++;
                ant=j;
            }
        }    
        printf("%d\n",n-sum-1);
    }
    return 0;
}

  

hdoj 5500 Reorder the Books

标签:

原文地址:http://www.cnblogs.com/tonghao/p/4964854.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!