码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2955 Robberies (01背包)

时间:2014-07-20 00:11:39      阅读:268      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   strong   

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11297    Accepted Submission(s): 4190



Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

bubuko.com,布布扣

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
2 4 6
 

Source
IDI Open 2009

反证法啊反证法。。。
就是开始把容量和价值搞反了,直膝箭。
#include<iostream>
using namespace std;
#define M 105
double b[M],f[10000];
int a[M];
double min(double x,double y)
{
    return x=x>y?x:y;
}
int main(int i,int j,int k)
{   
    double t;
    int n,v;
    while(cin>>k)
    {   
    while(k--)
    {      
     v=0;
     cin>>t>>n;
     t=1-t;
     for(i=1;i<=n;i++)
      {
        cin>>a[i]>>b[i];
        v+=a[i];
        b[i]=1-b[i];
     } 
    memset(f,0,sizeof(f));    f[0]=1;
      for(i=1;i<=n;i++)
      for(j=v;j>=a[i];j--)
        f[j]=min(f[j],f[j-a[i]]*b[i]);
      for(i=v;i>=0;i--)
        if(f[i]>=t)
        {
          cout<<i<<endl;
          break;
        } 
    } 
    } 
    return 0;
}

HDU 2955 Robberies (01背包),布布扣,bubuko.com

HDU 2955 Robberies (01背包)

标签:des   style   http   java   color   strong   

原文地址:http://blog.csdn.net/qq2256420822/article/details/37963037

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!