码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1081 To The Max

时间:2015-11-15 17:43:15      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10233    Accepted Submission(s): 4923


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

 

Output
Output the sum of the maximal sub-rectangle.
 

 

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
 

 

Sample Output
15
 
 
 
 
 
 
 
 
 

#include<stdio.h>
#include<string.h>
int a[105][105],n,b[2][105],c[105],dp[105];
int max(int x,int y)
{
if(x>y)
return x;
return y;
}
int L()
{
int i,m=-9999;
dp[0]=0;
for(i=1; i<=n; i++)
{
dp[i]=max(dp[i-1]+c[i],dp[i]);
if(m<dp[i])
m=dp[i];
}
return m;
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
int i,j,k,m,Max=-99999;
for(i=1; i<=n; i++)
for(j=1; j<=n; j++)
scanf("%d",&a[i][j]);
for(i=1; i<=n; i++)
{
memset(b,0,sizeof(b));
for(k=i; k<=n; k++)
{
for(j=1; j<=n; j++)
{
dp[j]=c[j]=b[k%2][j]=b[(k-1)%2][j]+a[k][j];
}
m=L();
if(Max<m)
Max=m;
}
}
printf("%d\n",Max);
}
return 0;
}

HDU 1081 To The Max

标签:

原文地址:http://www.cnblogs.com/-lgh/p/4966826.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!