码迷,mamicode.com
首页 > 其他好文 > 详细

HDU4452 Running Rabbits

时间:2015-11-16 22:45:39      阅读:324      评论:0      收藏:0      [点我收藏+]

标签:

涉及知识点:

1. direction数组。

2. 一一映射(哈希)。

 

 

Running Rabbits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1565    Accepted Submission(s): 1099

Problem Description

Rabbit Tom and rabbit Jerry are running in a field. The field is an N×N grid. Tom starts from the up-left cell and Jerry starts from the down-right cell. The coordinate of the up-left cell is (1,1) and the coordinate of the down-right cell is (N,N)。A 4×4 field and some coordinates of its cells are shown below:

技术分享

The rabbits can run in four directions (north, south, west and east) and they run at certain speed measured by cells per hour. The rabbits can‘t get outside of the field. If a rabbit can‘t run ahead any more, it will turn around and keep running. For example, in a 5×5 grid, if a rabbit is heading west with a speed of 3 cells per hour, and it is in the (3, 2) cell now, then one hour later it will get to cell (3,3) and keep heading east. For example again, if a rabbit is in the (1,3) cell and it is heading north by speed 2,then a hour latter it will get to (3,3). The rabbits start running at 0 o‘clock. If two rabbits meet in the same cell at k o‘clock sharp( k can be any positive integer ), Tom will change his direction into Jerry‘s direction, and Jerry also will change his direction into Tom‘s original direction. This direction changing is before the judging of whether they should turn around.
The rabbits will turn left every certain hours. For example, if Tom turns left every 2 hours, then he will turn left at 2 o‘clock , 4 o‘clock, 6 o‘clock..etc. But if a rabbit is just about to turn left when two rabbit meet, he will forget to turn this time. Given the initial speed and directions of the two rabbits, you should figure out where are they after some time.

Input

There are several test cases.
For each test case:
The first line is an integer N, meaning that the field is an N×N grid( 2≤N≤20).
The second line describes the situation of Tom. It is in format "c s t"。c is a letter indicating the initial running direction of Tom, and it can be ‘W‘,‘E‘,‘N‘ or ‘S‘ standing for west, east, north or south. s is Tom‘s speed( 1≤s<N). t means that Tom should turn left every t hours( 1≤ t ≤1000).
The third line is about Jerry and it‘s in the same format as the second line.
The last line is an integer K meaning that you should calculate the position of Tom and Jerry at K o‘clock( 1 ≤ K ≤ 200).
The input ends with N = 0.

Output

For each test case, print Tom‘s position at K o‘clock in a line, and then print Jerry‘s position in another line. The position is described by cell coordinate.

Sample Input

4 E 1 1 W 1 1 2 4 E 1 1 W 2 1 5 4 E 2 2 W 3 1 5 0

Sample Output

2 2 3 3 2 1 2 4 3 1 4 1

Source

2012 Asia JinHua Regional Contest

Recommend

zhuyuanchen520   |   We have carefully selected several similar problems for you:  55665565556455635562

Statistic | Submit | Discuss | Note

 

 

#include<stdio.h>

int dir[4][2] = {-1, 0, 0, -1, 1, 0, 0, 1};

int Map[256];
int Map1[256];

int main() {
    Map[‘N‘] = 0;
    Map[‘W‘] = 1;
    Map[‘S‘] = 2;
    Map[‘E‘] = 3;
    Map1[‘N‘] = ‘W‘;
    Map1[‘W‘] = ‘S‘;
    Map1[‘S‘] = ‘E‘;
    Map1[‘E‘] = ‘N‘;
    int n;
    while(~scanf("%d", &n), n) {
        char d1[2], d2[2];
        int s1, s2;
        int t1, t2;
        scanf("%s%d%d", d1, &s1, &t1);
        scanf("%s%d%d", d2, &s2, &t2);
        int k;
        scanf("%d", &k);
        int x1 = 1, y1 = 1, x2 = n, y2 = n;
        for(int i = 0; i < k; i++) {
            int id = Map[d1[0]];
            if(!dir[id][0]) {
                y1 += s1 * dir[id][1];
                if(y1 <= 0) {
                    y1 = 2 - y1;
                    d1[0] = ‘E‘;
                }
                if(y1 > n) {
                    y1 = 2 * n - y1;
                    d1[0] = ‘W‘;
                }
            } else {
                x1 += s1 * dir[id][0];
                if(x1 <= 0) {
                    x1 = 2 - x1;
                    d1[0] = ‘S‘;
                }
                if(x1 > n) {
                    x1 = 2 * n - x1;
                    d1[0] = ‘N‘;
                }
            }
            id = Map[d2[0]];
            if(!dir[id][0]) {
                y2 += s2 * dir[id][1];
                if(y2 <= 0) {
                    y2 = 2 - y2;
                    d2[0] = ‘E‘;
                }
                if(y2 > n) {
                    y2 = 2 * n - y2;
                    d2[0] = ‘W‘;
                }
            } else {
                x2 += s2 * dir[id][0];
                if(x2 <= 0) {
                    x2 = 2 - x2;
                    d2[0] = ‘S‘;
                }
                if(x2 > n) {
                    x2 = 2 * n - x2;
                    d2[0] = ‘N‘;
                }
            }
            if(x1 == x2 && y1 == y2) {
                int tmp = d1[0];
                d1[0] = d2[0];
                d2[0] = tmp;
            } else {
                if(!((i + 1) % t1))
                    d1[0] = Map1[d1[0]];
                if(!((i + 1) % t2))
                    d2[0] = Map1[d2[0]];
            }
        }
        printf("%d %d\n%d %d\n", x1, y1, x2, y2);
    }
    return 0;
}

 

  

 

HDU4452 Running Rabbits

标签:

原文地址:http://www.cnblogs.com/xzrmdx/p/4970118.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!