码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1789 Truck History 最小生成树

时间:2014-07-20 10:46:08      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:poj   c++   

Truck History
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 17606   Accepted: 6784

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company‘s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.


#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

#define M 2005
int f[M];
char str[M][10];

struct node
{
	int x,y,d;
}s[5000005];

int find(int x)     //查找
{
	return f[x]==x? x : f[x]=find(f[x]);
}

int cmp(node a,node b)    //按路径从小到大排序
{
	return a.d<b.d;
}

int main()
{
	int n;
	while(cin>>n && n)
	{
		int i,j,l,cur=0;
		for(i=1;i<=n;i++)
		{
			f[i]=i;
			cin>>str[i];
			for(j=1;j<=i;j++)
			{
				int t=0;
				for(l=0;l<7;l++)    //求距离
					if(str[i][l] != str[j][l])
						t++;
					s[cur].x = i;
					s[cur].y = j;
					s[cur].d = t;
					cur++;
			}
		}
		
		sort(s,s+cur,cmp);
		int sum=0;
		for(i=0;i<cur;i++)
		{
			int xi = find(s[i].x);
			int yi = find(s[i].y);
			if(xi != yi)    //判断是否在同一集合
			{
				sum += s[i].d;
				f[xi] = yi;    //合并
			}
		}
		
		printf("The highest possible quality is 1/%d.\n",sum);
	}
	
	return 0;
}


POJ 1789 Truck History 最小生成树

标签:poj   c++   

原文地址:http://blog.csdn.net/hyccfy/article/details/37989151

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!