码迷,mamicode.com
首页 > 其他好文 > 详细

kmp算法(Oulipo)

时间:2014-07-22 22:48:34      阅读:182      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   

http://www.cnblogs.com/dolphin0520/archive/2011/08/24/2151846.html

http://www.matrix67.com/blog/archives/115



Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22468   Accepted: 8962

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

bf算法RE=。=

#include<iostream>
#include<string>
using namespace std;
int main()
{
	int n,c;
	cin>>n;
	for(c=1;c<=n;c++)
	{
		char s[100005],t[10005];
		cin>>t;
		cin>>s;
		int slen,tlen;
		tlen=strlen(t);
		slen=strlen(s);
		int i,j;
		int sum=0;
		for(i=0;i<slen;i++)
		{
			j=0;
			while(t[j]==s[i]&&j<tlen)
			{
				i++;
				j++;
			}
			if(j==tlen)
				sum=sum+1;
            i=i-j+1;
		}
		cout<<sum<<endl;
	}
    return 0;
}


kmp算法求next[]数组~

#include<iostream>
#include<string>
using namespace std;
int next[10005];
char s[1000005],t[10005];
void getnext(char *p,int *next)
{
    int j=0,k=-1;
     next[0]=-1;
     while(!j || t[j]!='\0')
     {
         if(k==-1 || t[j]==t[k])
         {
             j++;
             k++;
             if(t[j]!=t[k])
                 next[j]=k;
             else
                 next[j]=next[k];
         }
         else k=next[k];
     }
}
int main()
{
	int n,c;
	cin>>n;
	for(c=1;c<=n;c++)
	{
		cin>>t>>s;
		int slen,tlen;
		slen=strlen(s);
		tlen=strlen(t);
		getnext(t,next);
		int i=0,j=0,sum=0;
		while(i<slen)
		{
			if(j==-1||s[i]==t[j])
			{
				i++;
				j++;
			}
			else
			{
				j=next[j];       
			}
			if(j==tlen)
			{
				sum=sum+1;
				j=next[j];
			}
		}
		cout<<sum<<endl;
	}
	return 0;
}

/*

  3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
*/



kmp算法(Oulipo),布布扣,bubuko.com

kmp算法(Oulipo)

标签:des   style   blog   http   color   os   

原文地址:http://blog.csdn.net/sunshumin/article/details/37988611

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!