标签:
看完题目后,题目要求:
设时间为t
(x+mt)%L = (y+nt)%L
( x-y + (m-n)*t )= k*L (k是整数,可为负)
然后就是经典的
xa+yb=c 求解x,y的经典题目了。
/*
xa+yb=c
先求 xa+yb=gcd(a,b)
如果c%gcd(a,b)不为0,则没有整数解
求出x0,y0后,
x0 *= c/gcd(a,b)
y0 *= c/gcd(a,b)
即为xa+yb = c 的一组解。
怎么求所有解呢, 求出xa+yb=0
x = sx* b/gcd(a,b)
y = sy* -a/gcd(a,b)
因为整个方程是对L取模的,对应的也就是b取模,所以sy可以任意取。
设s=b/gcd(a,b)
则x0的最小正整数解为: (x0%s+s)%s
*/
最后在所有解t中找出一个最小正整数。
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 100349 | Accepted: 19268 |
Description
Input
Output
Sample Input
1 2 3 4 5
Sample Output
4
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <string>
#include <math.h>
#include <stdlib.h>
using namespace std;
typedef long long ll;
void extendgcd(ll a,ll b,long long &x,long long &y)
{
if(a%b==0)
{
//到了终止条件
x=0; y=1;
return ;
}
extendgcd(b,a%b,x,y);
long long tmpx;
tmpx=y;
y=x-(a/b)*y;
x=tmpx;
}
long long GCD(long long a,long long b)
{
if(b==0) return a;
return GCD(b,a%b);
}
int main()
{
ll x,y,m,n,l;
while(cin>>x>>y>>m>>n>>l)
{
x%=l;
y%=l;
if(m==n)
{
printf("Impossible\n");
continue;
}
ll R,P;
if(m>n)
{
R = m-n;
P = y-x;
}
else
{
R = n-m;
P = x-y;
}
ll gcd = GCD(R,l);
if(P%gcd != 0)
{
printf("Impossible\n");
continue;
}
ll k0,t0;
extendgcd(l,R,k0,t0);
t0 *= (P/gcd);
ll s=l/gcd;
cout << (t0%s+s)%s<<endl;
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/chenhuan001/p/4976554.html