码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5534/ 2015长春区域H.Partial Tree DP

时间:2015-11-19 14:53:59      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:

Partial Tree

 

Problem Description
In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree.

You find a partial tree on the way home. This tree has n技术分享 nodes but lacks of n1技术分享 edges. You want to complete this tree by adding n1技术分享 edges. There must be exactly one path between any two nodes after adding. As you know, there are n技术分享n2技术分享技术分享 ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is f(d)技术分享 , where f技术分享 is a predefined function and d技术分享 is the degree of this node. What‘s the maximum coolness of the completed tree?
 

 

Input
The first line contains an integer T技术分享 indicating the total number of test cases.
Each test case starts with an integer n技术分享 in one line,
then one line with n1技术分享 integers f(1),f(2),,f(n1)技术分享 .

1T2015技术分享
2n2015技术分享
0f(i)10000技术分享
There are at most 10技术分享 test cases with n>100技术分享 .
 

 

Output
For each test case, please output the maximum coolness of the completed tree in one line.
 

 

Sample Input
2 3 2 1 4 5 1 4
 

 

Sample Output
5 19
 
题意:给你n个点,给你1到n-1的度数的价值,让你构造一棵树这颗树的价值就是,度数代表的价值和,问最大是多少,
 
题解:首先度的总和为2(n-1),并且每个节点度不为0。如果用二维dp[i][j]表示第i个节点还剩j个度的最优值,是没问题,但是复杂度为o(n3)。但是其实每个节点都要分配一个度,那么我们先给每个节点分配一个度,剩下n-2的度分给n个点,可以减掉一维,dp[i]表示i个度的最优值,因为度的个数是严格小于节点个数的。背包转移的权值为val[i]-val[1](可能有负数)
 
技术分享
#include<cstdio>
using namespace std ;
#define inf 1000000
int main(){
  int dp[2016],a,b,n,i,T,j;
   scanf("%d",&T);
     while(T--){
        scanf("%d%d",&n,&a);
        for( i=1;i<n;i++){dp[i]=-inf;}
        for( i=2;i<n;i++){
                scanf("%d",&b);b=b-a;
            for( j=i-1;j<=n-2;j++){
                if(dp[j-(i-1)]+b>dp[j])
                dp[j]=dp[j-(i-1)]+b;
            }
        }
       printf("%d\n",n*a+dp[n-2]);
     }
  return 0;
}
代码

 

HDU 5534/ 2015长春区域H.Partial Tree DP

标签:

原文地址:http://www.cnblogs.com/zxhl/p/4977505.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!