码迷,mamicode.com
首页 > 其他好文 > 详细

uva - Broken Keyboard (a.k.a. Beiju Text)(链表)

时间:2015-11-21 22:37:49      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:

              

11988 - Broken Keyboard (a.k.a. Beiju Text)

You’re typing a long text with a broken keyboard. Well it’s not so badly broken. The only problem
with the keyboard is that sometimes the “home” key or the “end” key gets automatically pressed
(internally).
You’re not aware of this issue, since you’re focusing on the text and did not even turn on the
monitor! After you finished typing, you can see a text on the screen (if you turn on the monitor).
In Chinese, we can call it Beiju. Your task is to find the Beiju text.
Input
There are several test cases. Each test case is a single line containing at least one and at most 100,000
letters, underscores and two special characters ‘[’ and ‘]’. ‘[’ means the “Home” key is pressed
internally, and ‘]’ means the “End” key is pressed internally. The input is terminated by end-of-file
(EOF).
Output
For each case, print the Beiju text on the screen.
Sample Input
This_is_a_[Beiju]_text
[[]][][]Happy_Birthday_to_Tsinghua_University
Sample Output
BeijuThis_is_a__text
Happy_Birthday_to_Tsinghua_University

题解:链表,好题,代码好吊,看了半天,越看越感觉吊;

代码:

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=1e5+100;
int en,cur,next[MAXN];
char s[MAXN];
int main(){
	while(~scanf("%s",s+1)){
		int len=strlen(s+1);
		cur=en=0;
		next[0]=0;
		for(int i=1;i<=len;i++){
			if(s[i]==‘[‘)cur=0;
			else if(s[i]==‘]‘)cur=en;
			else{
				next[i]=next[cur];
				next[cur]=i;
				if(cur==en)en=i;
				cur=i;
			}
		}
		for(int i=next[0];i!=0;i=next[i])printf("%c",s[i]);
		puts("");
	}
	return 0;
}

  

uva - Broken Keyboard (a.k.a. Beiju Text)(链表)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/4984810.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!