码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1506 Largest Rectangle in a Histogram (dp左右处理边界的矩形问题)

时间:2015-11-21 22:47:40      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:

E - Largest Rectangle in a Histogram
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description:

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
技术分享
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0 

Sample Output

8
4000
本题的题意是给出若干个长方形,高度不一定,问你求得时在整个图形的范围内最大的面积是多少·
由于本题的高度很高,所以用int会出问题,
最好改成long long可以过了
下面给出代码
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=100005;
typedef long long int ll;
ll l[maxn],r[maxn],h[maxn];
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        if(!n)
        break;
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        memset(h,0,sizeof(h));
  //          memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++){
           scanf("%lld",&h[i]);

        }
        l[1]=1;
        r[n]=n;

        for(int i=2;i<=n;i++){
             int tmp=i;
            while(tmp>1&&h[i]<=h[tmp-1])
            tmp=l[tmp-1];

            l[i]=tmp;
        }

        for(int i=n-1;i>=1;i--){
              int tmp=i;
            while(tmp<n&&h[i]<=h[tmp+1])
            tmp=r[tmp+1];
            r[i]=tmp;
        }
        ll ans=-1;
        for(int i=1;i<=n;i++){
           ll tmp=(r[i]-l[i]+1)*h[i];
            ans=max(ans,tmp);
        }
      printf("%lld\n",ans);
    }
    return 0;
}

 

HDU 1506 Largest Rectangle in a Histogram (dp左右处理边界的矩形问题)

标签:

原文地址:http://www.cnblogs.com/13224ACMer/p/4984750.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!