码迷,mamicode.com
首页 > 其他好文 > 详细

virtual judge(专题一 简单搜索 B)

时间:2015-11-27 21:52:11      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#‘ and empty cells are represented by a ‘.‘. Your starting position is indicated by ‘S‘ and the exit by the letter ‘E‘. There‘s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

三维迷宫水题
#include"cstdio"
#include"queue"
#include"cstring"
using namespace std;
const int MAXN=31;
char dun[MAXN][MAXN][MAXN];
int vis[MAXN][MAXN][MAXN];
struct node{
    int L,R,C;
    int step;
    node(int l,int r,int c,int s):L(l),R(r),C(c),step(s){}
    node(){}
};
int l,r,c;
int sl,sr,sc;
int el,er,ec;
int dl[6]={1,0,0,0,0,-1};
int dc[6]={0,1,0,-1,0,0};
int dr[6]={0,0,1,0,-1,0};
int bfs()
{
    queue<node> que;
    que.push(node(sl,sr,sc,0));
    vis[sl][sr][sc]=1;
    while(!que.empty())
    {
        node now=que.front();que.pop();
        if(now.L==el&&now.R==er&&now.C==ec)
        {
            return now.step;
        }
        for(int i=0;i<6;i++)
        {
            int nl=now.L+dl[i];
            int nr=now.R+dr[i];
            int nc=now.C+dc[i];
            if(0<=nl&&nl<l&&0<=nr&&nr<r&&0<=nc&&nc<c&&!vis[nl][nr][nc]&&dun[nl][nr][nc]!=#)
            {
                vis[nl][nr][nc]=1;
                que.push(node(nl,nr,nc,now.step+1));
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d%d%d",&l,&r,&c)!=EOF&&l!=0)
    {
        memset(vis,0,sizeof(vis));
        scanf("%*c");
        for(int i=0;i<l;i++)
        {
            for(int j=0;j<r;j++)
            {
                for(int z=0;z<c;z++)
                {
                    scanf("%c",&dun[i][j][z]);
                    if(dun[i][j][z]==S)
                    {
                        sl=i,sr=j,sc=z;
                    }
                    if(dun[i][j][z]==E)
                    {
                        el=i,er=j,ec=z;
                    }
                }
                scanf("%*c");
            }
            scanf("%*c");
        }
        
    int ans=bfs();
    if(ans!=-1)
    {
        printf("Escaped in %d minute(s).\n",ans);
    }
    else
    {
        printf("Trapped!\n");
    }
}
    return 0;
}

 

virtual judge(专题一 简单搜索 B)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5001706.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!