码迷,mamicode.com
首页 > 其他好文 > 详细

virtual judge(专题一 简单搜索 C)

时间:2015-11-27 23:34:49      阅读:238      评论:0      收藏:0      [点我收藏+]

标签:

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include"cstdio"
#include"queue"
#include"cstring"
using namespace std;
typedef pair<int,int> P;
const int MAXN=100005;
int vis[MAXN];
int n,k;
int bfs()
{
    queue<P> que;
    vis[n]=1;
    que.push(P(0,n));
    while(!que.empty())
    {
        P now = que.front();que.pop();
        if(now.second==k)
        {
            return now.first;
        }
        for(int i=-1;i<=1;i++)
        {
            int next;
            if(i==0) next=now.second*2;
            else    next=now.second+i;
            if(next>=0&&next<=MAXN&&!vis[next])//注意条件不能少,且顺序不能颠倒
            {
                vis[next]=1;
                que.push(P(now.first+1,next));
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        printf("%d\n",bfs());
    }
    return 0;
}

 

virtual judge(专题一 简单搜索 C)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5001925.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!