码迷,mamicode.com
首页 > 其他好文 > 详细

字符串去星

时间:2015-11-29 12:06:45      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:

字符串去星

Problem : 903

Time Limit : 1000ms

Memory Limit : 65536K

description

有一个字符串(长度小于100),要统计其中有多少个*,并输出该字符串去掉*后的新字符串。

input

输入数据有多组,每组1个连续的字符串;

output

在1行内输出该串内有多少个* 和去掉*后的新串。

sample_input

Goodggod223**df2*w
Qqqq*

sample_output

3 Goodggod223df2w
1 Qqqq

 

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    char a[120];
    int i,j,n;
    while(scanf("%s",a)!=-1)
    {
        n=0;j=0;
        for(i=0;i<strlen(a);i++)
        {
            if(a[i]==*)
            n++;
        }
        for(i=0,j=0;i<strlen(a);i++)
        if(a[i]!=*)
        {
            a[j]=a[i];
            j++;
        }
        a[j]=\0;
        printf("%d ",n);
        puts(a);
    }
    return 0;
}

 

字符串去星

标签:

原文地址:http://www.cnblogs.com/nefu929831238/p/5004438.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!