码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5586 (dp 思想)

时间:2015-12-01 01:40:49      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:

Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 507    Accepted Submission(s): 284
Problem Description
There is a number sequence A技术分享1技术分享,A技术分享2技术分享....A技术分享n技术分享技术分享

,
A技术分享1技术分享,A技术分享2技术分享....A技术分享n技术分享技术分享

,
A技术分享1技术分享,A技术分享2技术分享....A技术分享n技术分享技术分享

,
A技术分享1技术分享,A技术分享2技术分享....A技术分享n技术分享技术分享

,
A技术分享1技术分享,A技术分享2技术分享....A技术分享n技术分享技术分享

,
A技术分享1技术分享,A技术分享2技术分享....A技术分享n技术分享技术分享

,
A技术分享1技术分享,A技术分享2技术分享....A技术分享n技术分享技术分享
,you can select a interval [l,r] or not,all the numbers A技术分享i技术分享(lir)技术分享
will become f(A技术分享i技术分享)技术分享
.f(x)=(1890x+143)mod10007技术分享
.After that,the sum of n numbers should be as much as possible.What is the maximum sum?
 
Input
There are multiple test cases. First line of each case contains a single integer n.(1n10技术分享5技术分享)技术分享
Next line contains n integers A技术分享1技术分享,A技术分享2技术分享....A技术分享n技术分享技术分享
.(0A技术分享i技术分享10技术分享4技术分享)技术分享
It‘s guaranteed that n10技术分享6技术分享技术分享
.
 
Output
For each test case,output the answer in a line.
 
Sample Input
2
10000 9999
5
1 9999 1 9999 1
 
Sample Output
19999 22033
 
Source
 
传送门 http://acm.hdu.edu.cn/showproblem.php?pid=5586
类似杭电1003
题意  一串序列 可以只能更改一个区间 或不更改f(x)=(1890x+143)mod10007技术分享    更改操作为f(x)=(1890x+143)mod10007
询问 这串序列的和的最大值
做一个变形 每个值变为 f(x)-x 然后按照1003的方法 求最大连续区间的和 
dp[i]=max(dp[i],dp[i-1]+dp[i]);
 
f(x)=(1890x+143)mod10007技术分享
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n;
int bac(int s)
{
    return (1890*s+143)%10007;
}
int b[100005],a[100005];
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(b,0,sizeof(b));
        memset(a,0,sizeof(a));
        int re=0;
        for(int i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                re=re+a[i];
                b[i]=bac(a[i])-a[i];
            }
          //  int exm=0;
            int maxn=0;
          for(int i=1;i<n;i++)
          {
              if(b[i]+b[i-1]>b[i])
                b[i]=b[i]+b[i-1];
       if(b[i]>maxn)
                     maxn=b[i];

          }
        printf("%d\n",re+maxn);
    }
    return 0;
}

 

HDU 5586 (dp 思想)

标签:

原文地址:http://www.cnblogs.com/hsd-/p/5008883.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!