码迷,mamicode.com
首页 > 其他好文 > 详细

1027. Colors in Mars (20)【进制转换】——PAT (Advanced Level) Practise

时间:2015-12-03 07:16:54      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:

题目信息

1027. Colors in Mars (20)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input
15 43 71
Sample Output
#123456

解题思路

进制转换

AC代码

#include <stdio.h>
void outc(int a){
    if (a <= 9) printf("%d", a);
    else printf("%c", a-10+‘A‘);
}
void out(int a){
    if (a >= 13){
        outc(a/13);
        outc(a%13);
    }else{
        printf("0");
        outc(a);
    }
}
int main()
{
    int r, g, b;
    scanf("%d%d%d", &r, &g, &b);
    printf("#");
    out(r);
    out(g);
    out(b);
    printf("\n");
    return 0;
}

1027. Colors in Mars (20)【进制转换】——PAT (Advanced Level) Practise

标签:

原文地址:http://blog.csdn.net/xianyun2009/article/details/50149981

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!