码迷,mamicode.com
首页 > 其他好文 > 详细

More Divisors(反素数)

时间:2015-12-03 22:53:40      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:

More Divisors

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Everybody knows that we use decimal notation, i.e. the base of our notation is 10. Historians say that it is so because men have ten fingers. Maybe they are right. However, this is often not very convenient, ten has only four divisors -- 1, 2, 5 and 10. Thus, fractions like 1/3, 1/4 or 1/6 have inconvenient decimal representation. In this sense the notation with base 12, 24, or even 60 would be much more convenient.

The main reason for it is that the number of divisors of these numbers is much greater -- 6, 8 and 12 respectively. A good quiestion is: what is the number not exceeding n that has the greatest possible number of divisors? This is the question you have to answer.

Input:

The input consists of several test cases, each test case contains a integer n (1 <= n <= 1016).

Output:

For each test case, output positive integer number that does not exceed n and has the greatest possible number of divisors in a line. If there are several such numbers, output the smallest one.

Sample Input:

10
20
100

Sample Output:

6
12
60

题解:找小于等于n的因子个数最大的最小整数;

代码:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;
const double PI=acos(-1.0);
#define SI(x) scanf("%d",&x)
#define SL(x) scanf("%lld",&x)
#define PI(x) printf("%d",x)
#define PL(x) printf("%lld",x)
#define T_T while(T--)
#define P_ printf(" ")
typedef unsigned long long uLL;
const uLL INF=(uLL)~0;
int prim[16]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53};
uLL n,ans;
int nn;
void dfs(int pos,uLL v,int num){
	if(num==nn)ans=min(ans,v);
	if(num>nn&&v<=n)nn=num,ans=v;
	for(int i=1;i<=63;i++){
		if(v*prim[pos]>n)break;
		dfs(pos+1,v*=prim[pos],num*(i+1));
	}
}
int main(){
	while(~scanf("%llu",&n)){
		nn=0;ans=INF;
		dfs(0,1,1);
		printf("%llu\n",ans);
	}
	return 0;
}

  


 

More Divisors(反素数)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/5017559.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!