码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1001 Sum Problem

时间:2014-07-22 00:27:36      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:des   style   java   color   os   strong   

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 275913    Accepted Submission(s): 68867


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
1 100
 

Sample Output
1 5050
 



#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i,sum=0;
        for(i=1;i<=n;i++)
        {
            sum+=i;
        }
        printf("%d\n",sum);
        printf("\n");
    } 
    return 0;
}


HDOJ 1001 Sum Problem,布布扣,bubuko.com

HDOJ 1001 Sum Problem

标签:des   style   java   color   os   strong   

原文地址:http://blog.csdn.net/qq_16767427/article/details/38013133

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!