标签:des style java color 使用 os
As Easy As A+B
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36141 Accepted Submission(s): 15642
Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in
the same line.
It is guarantied that all integers are in the range of 32-int.
Output
For each case, print the sorting result, and one line one case.
Sample Input
2
3 2 1 3
9 1 4 7 2 5 8 3 6 9
Sample Output
使用快排拍一下序就可以了
#include<stdio.h>
#include<stdlib.h>
int a[1002];
int cmp (const void *a,const void *b)
{
return *(int *)a-*(int *)b;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int N,i;
scanf("%d ",&N);
for(i=0;i<N;i++)
scanf("%d",&a[i]);
qsort(a,N,sizeof(a[0]),cmp);
printf("%d",a[0]);
for(i=1;i<N;i++)
printf(" %d",a[i]);
printf("\n");
}
return 0;
}
HDOJ 1040 As Easy As A+B,布布扣,bubuko.com
HDOJ 1040 As Easy As A+B
标签:des style java color 使用 os
原文地址:http://blog.csdn.net/qq_16767427/article/details/38009881