码迷,mamicode.com
首页 > 其他好文 > 详细

1041. Be Unique (20)【水题】——PAT (Advanced Level) Practise

时间:2015-12-06 01:50:22      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:

题目信息

1041. Be Unique (20)

时间限制100 ms
内存限制65536 kB
代码长度限制16000 B

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=10^5) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print “None” instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None

解题思路

记录每个数出现次数,第一个出现一次的为所求

AC代码

#include <cstdio>
#include <map>
#include <vector>
using namespace std;
int main()
{
    int n, t;
    vector<int> v;
    map<int, int> mp;
    scanf("%d", &n);
    for (int i = 0; i < n; ++i){
        scanf("%d", &t);
        v.push_back(t);
        mp[t]++;
    }
    bool flag = false;
    for (int i = 0; i < v.size(); ++i){
        if (mp[v[i]] == 1){
            printf("%d\n", v[i]);
            flag = true;
            break;
        }
    }
    if (!flag){
        printf("None\n");
    }
    return 0;
}

1041. Be Unique (20)【水题】——PAT (Advanced Level) Practise

标签:

原文地址:http://blog.csdn.net/xianyun2009/article/details/50191059

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!