标签:
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N‘s!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:4 1 2 4 -1 4 7 6 -2 -3Sample Output:
43
#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<long long int> Nina0, Nouta0,Ninu0,Noutu0;
char result[100] = { ‘0 ‘};
bool cmp1(int a, int b) {
return a > b;
}
bool cmp2(int a, int b) {
return a < b;
}
void AddSum(long long int a) {
int jinwei = 0;
int temp;
int i = 0;
while (a!=0||jinwei!=0) {
temp = a % 10;
a = a / 10;
if (temp + result[i] + jinwei <= ‘9‘) {
result[i] = temp + result[i] + jinwei;
jinwei = 0;
}
else {
result[i] = temp + result[i] + jinwei - 10;
jinwei = 1;
}
i++;
}
}
int main(void) {
//long long int k = 1073741825;
//long long int p;
//p = k*k *10000;
//cout << p;
int nc, np;
cin >> nc;
for (int i = 0; i < 99; i++)
result[i] = ‘0‘;
for (int i = 0; i < nc; i++) {
long long int temp;
cin >> temp;
if (temp > 0)
Nina0.push_back(temp);
else
Ninu0.push_back(temp);
}
cin >> np;
for (int i = 0; i < np; i++) {
int temp2;
cin >> temp2;
if (temp2 > 0)
Nouta0.push_back(temp2);
else
Noutu0.push_back(temp2);
}
if(Nina0.empty()==false)
sort(Nina0.begin(), Nina0.end(), cmp1);
if(Nouta0.empty()==false)
sort(Nouta0.begin(), Nouta0.end(), cmp1);
if (Ninu0.empty() == false)
sort(Ninu0.begin(), Ninu0.end(), cmp2);
if (Noutu0.empty() == false)
sort(Noutu0.begin(), Noutu0.end(), cmp2);
int index;
long long int sum = 0;
if (Nina0.empty() == false && Ninu0.empty() == false && Nouta0.empty() == false && Noutu0.empty() == false) {
if (Nina0.size() >= Nouta0.size()) {
index = Nouta0.size();
}
else
index = Nina0.size();
for (int i = 0; i < index; i++) {
sum = Nina0[i] * Nouta0[i];
AddSum(sum);
}
if (Ninu0.size() <= Noutu0.size()) {
index = Ninu0.size();
}
else
index = Noutu0.size();
for (int i = 0; i < index; i++) {
sum = Ninu0[i] * Noutu0[i];
AddSum(sum);
}
}
else if (Nina0.empty() == true || Nouta0.empty() == true) {
if (Ninu0.size() <= Noutu0.size()) {
index = Ninu0.size();
}
else
index = Noutu0.size();
for (int i = 0; i < index; i++) {
sum = Ninu0[i] * Noutu0[i];
AddSum(sum);
}
}
else if (Ninu0.empty() == true || Noutu0.empty() == true) {
if (Nina0.size() >= Nouta0.size()) {
index = Nouta0.size();
}
else
index = Nina0.size();
for (int i = 0; i < index; i++) {
sum = Nina0[i] * Nouta0[i];
AddSum(sum);
}
}
int flag = 0;
for (int i = 99; i >= 0; i--) {
if (result[i] > ‘0‘) {
flag = i;
break;
}
}
for (int i = flag; i >= 0; i--)
cout << result[i];
return 0;
}
标签:
原文地址:http://www.cnblogs.com/zzandliz/p/5023131.html