标签:
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:5 7 5 1 2 3 4 5 6 7 3 2 1 7 5 6 4 7 6 5 4 3 2 1 5 6 4 3 7 2 1 1 7 6 5 4 3 2Sample Output:
YES NO NO YES NO
#include <iostream>
#include <vector>
using namespace std;
vector<int> inStack;
int mark[1010];
int main(void) {
int n,m,k;
cin >> m >> n >> k;
for (int j = 0; j < k; j++) {
int temp, maxPush = 0;
bool flag = true;
inStack.clear();
for (int i = 0; i < 1002; i++) {
mark[i] = 0;
}
cin >> temp;maxPush = temp;
mark[temp]++;
if (temp > m || temp < 0)
flag = false;
for (int i = 1; i < temp; i++) {
inStack.push_back(i);
mark[i] = 1;
}
for (int i = 1; i < n; i++) {
int lastpop = temp;
cin >> temp;
mark[temp]++;
if (temp > n || temp < 1)
flag = false;
if (temp <= maxPush + m - inStack.size() && temp>lastpop) {
if (temp > maxPush)
maxPush = temp;
for (int q = lastpop + 1; q < temp; q++) {
if(mark[q]==0)
inStack.push_back(q);
mark[q]++;
}
}
else if (inStack.size()>0&&temp == inStack[inStack.size()-1]) {
inStack.pop_back();
}
else {
flag = false;
}
}
if (flag == true)
cout << "YES" << endl;
else
cout << "NO" << endl;
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/zzandliz/p/5023171.html