标签:
Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:
Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.
Input Specification:
Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.
Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
Sample Input:10 3 5 7 2 6 4 9 0 8 1Sample Output:
9
#include <iostream>
#include <vector>
using namespace std;
vector<int> num;
int a[100010] = { 0 };
int main(void) {
int n;
cin >> n;
for (int i = 0; i < n; i++) {
int temp;
cin >> temp;
num.push_back(temp);
}
int count = 0;
for (int i = 0; i < n; i++) {
if (num[i] != i)
count++;
else
a[i]++;
}
if (num[0] == 0)
count++;
count--;
a[0] = 1;
int j = 0, p = 0;
int check = 0;
bool flag = false;
for (int q = 0; q < n; q++)
{
while (a[j] == 1) {
j = num[j];
a[j] ++;
}
if (a[q] == 0) {
j = q;
a[j] = 1;
count++;
continue;
}
}
cout << count ;
return 0;
}
1067. Sort with Swap(0,*) (25)
标签:
原文地址:http://www.cnblogs.com/zzandliz/p/5023212.html