标签:
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it‘s easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:3.2.1 10.16.27Sample Output:
14.1.28
#pragma warning(disable:4996)
#include <stdio.h>
#include <iostream>
using namespace std;
int main(void) {
int ag, as, ak;
int bg, bs, bk;
int cg=0, cs=0, ck=0;
char a[9], b[9];
scanf("%s",a);
sscanf(a, "%d.%d.%d", &ag, &as, &ak);
scanf("%s", b);
sscanf(b, "%d.%d.%d", &bg, &bs, &bk);
ck = ak + bk;
if (ck >= 29) {
ck -= 29;
cs++;
}
cs += (as + bs);
if (cs >= 17) {
cs -= 17;
cg++;
}
cg += (ag + bg);
cout << cg << "." << cs << "." << ck;
/*while (true)
{
}*/
return 0;
}
标签:
原文地址:http://www.cnblogs.com/zzandliz/p/5023189.html